BMS heating up, how to diagnose.

I got a very old used, non-running ebike on CL, it had a 37V battery but no charger. I ended up removing the electrics because I couldn't find parts, the controller was damaged no joy finding one.

I bought a charger on BangGood and charged the battery about 3 wks ago, it's still holding 37.7V. I left the charger connected for maybe 4 hrs, after disconnecting the charger, with no load on the battery - nothing connected to it, the BMS has a hot spot on it 10 min's after charging. I couldn't find anything else warm but quickly unplugged the 8-pin white connector because I had read that the BMS can help prevent explsions due to too rapid charge/discharge and I didn't want to take any chances. Interestingly with the battery red and black leads attached to the BMS but the white 8-pin connector disconnected it stopped getting hot. That will help in the diagnosis if I try to repair it.

I don't know anything about Lithium Ion batteries or BMS tech, so I thought I'd ask here, how would I go about diagnosing this?
- The batteries have a batch code 20150803, can I assume that means Aug 2015?
- If the batteries are 2015 does that mean they're not worth keeping?
- How do I verify the battery cells are working normally before spending $ on it if it's worth repairing?
- If the BMS is faulty, is it worthwhile attempting a repair?
- will any 37V BMS with the same 8-pin white connector be suitable as a replacement?

Thanks in advance, I'm a complete newbie, I was an electronics tech and am familiar with basic electronic concepts.
Mike
 

Attachments

Thread starter Similar threads Forum Replies Date
S Power Management 3
D General Power Chat 4
Top